Learning Photoshop with GIMP 1

Introduction:

Hello everyone! It is the hope of everyone at CanCODE and EUReKA! that, despite recent
events necessitating the closure of schools, we can still teach important digital skills to students
in the Kamloops area.

This document will outline a detailed introduction to photoshop using GIMP. It will also be
accompanied by an optional video tutorial that will walk through all steps outlined in this
document. Before we get started, though, it is important that we make sure we have everything
we need:

Supplies Needed:

A Computer

Internet Connection

Folder titled ‘GIMP Part 1 Package’ - Downloaded from our CanCode
Workshops page. Save this folder directly to your desktop.

GIMP Installed
1. Click the Download button on the main page.
2. Click the big orange button that says “Download GIMP
directly”.

The GIMP Tools document has lots of tips in it, so take a look if you are stuck!

Part One:

What are the differences between photoshop and photo editing?

Photoshop: removing scars or imperfections from a person’s face, changing their body, or
combining two images together

Photo Editing: | changing brightness, contrast, saturation, colour, fade, shadows, highlights, etc.

As we can see, photoshop and photo editing are very different things. If you'd like to try your
hand at distinguishing something that’'s been photoshopped from a real image, try the first 10
levels of this game.

If that link didn’t work for you, here’s the full URL. Copy and paste it into your web browser:
https://landing.adobe.com/en/na/products/creative-cloud/69308-real-or-photoshop/index.html



https://www.tru.ca/eureka/cancode-workshops.html
https://www.tru.ca/eureka/cancode-workshops.html
https://www.gimp.org/
https://landing.adobe.com/en/na/products/creative-cloud/69308-real-or-photoshop/index.html
https://landing.adobe.com/en/na/products/creative-cloud/69308-real-or-photoshop/index.html
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How’d you do? If you didn’t do so well, that’s okay. Photoshopped images are hard to tell apart
from real images already, and the technology is only getting better. That’s why we have to be
very careful with what images we believe are real.

Part Two:

Colors Tools Filters Windows Help

The areas highlighted in red in the above image are the tool areas. They allow you to select
different tools to work with.

The area highlighted in blue in the above image is the tool options bar. It lets you change
different features of the tool you are using.
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The ‘paint tools’ part of the tools options Colors Tools | Fiters
menu allows you to draw parts of your image P s
in different ways, such as blurring, erasing, or Transform Toos i
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The most relevant usage of the tool options in 7SSl =
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Incremental

Layers are another important element of GIMP to discuss before you start working with GIMP.
GIMP uses layers to order photos. These layers act like normal layers - an easy mental
reference is sheets of paper. For stacked sheets of paper, will you see the bottom layer through
the top? No - not unless you cut away parts of the top layer. GIMP behaves the same when
working with photos.
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Activity #1: Selective Colouring

For this first activity, we are going to use layers in GIMP to selectively colour an image, like the

Lol

one below:

Procedure:

1.

2.

First, we need to have GIMP installed and open. We also need the “Photoshop 1
Resources” folder downloaded and saved to the Desktop. Then start up GIMP, and in
the top left of the GIMP window, you want to click File -> Open...

GMU Image Manipulation Program

File Edit Select Wiew Image Layer (
1 New.. Ctrl+MN
Create >
Ctrl+ 0

Open as Layers... Ctrl

an image f

) Open Location...

Open Recent

In the new window, you want to locate “Desktop” on the left side of the new window, then
locate the Resources folder you downloaded earlier. Double click to open it, then open
the folder called Activity #1.
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Open Image X

Name e  Modified

WmR

w All F
lect File Type (Automatically Detected)

Help

Open Image X

ow All Files

* Select File Type (Automatically Detected)

Help




Learning Photoshop with GIMP 1

3. Inside is one image. Click Open in the bottom right of the window to open it in GIMP.

Open Image x

ym Home

Modified

All Fil

* Select File Type (Automatically Detected)

Help

Aa [Activity_1_Picture] (imported)-2.0 (RGB coler 8-bit gamma integer, GIMP built-in sRGB, 1 layer) 600x400 - GIMP = B x

File Edit Select View Image Layer Filters Windows Help

100.0 +

Activity_1_Pic

|_Picture,j
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In the bottom right of the GIMP window is the Layers tab. As you can see, we only have
one layer right now. We want to right click the small image in the Layers tab, then click
Duplicate Layer in the new options. You should see two layers in the Layers tab now.

& [Activity_1_Picture] (imported)-2.0 (RGB color -bit gamma integer, GIMP built-in sRGE, 1 layer) 600x400 - GIMP - o b

Tools Filters Windows Help

100.0 &

+ m
Activity_1_Pic

px v 100% v Activity_1_Picture
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5. With the top layer selected (the first one in the list), at the top of the window, we want to
go to Colors -> Saturation... and set the Scale to 0. Then click OK. You should now have
two layers; one black and white and one in colour. The black and white one should be on
top.

S TTActivity_1_Picture] (imported])-2.0 (RGE color 2-bit garmma integer, GIMP built-in sRGE, 2 layers) 600400 — GIMP
File Edit Select View |mage Layer Colors Tools Filters Windows
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6. Next, we need to add some transparency to the image. Transparency means the same
thing as see-through, and is essential for us to selectively colour this image. Go to
Layers in the top of the window (Hint: it's next to Colors!), then hover over Transparency,
and click “Add Alpha Channel”. You will not see an immediate effect, but this is very
important.
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S C[Activity_1_Picture] (imported)-2.0 (RGE color 8-bit gamma integer, GIMP built-in sRGE, 2 layers) 600x400 - GIMP
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7. Finally, we need to find the eraser tool in the tool area. If you hove over the icon of a
tool, GIMP will tell you what it is. Once you find the eraser tool, click on it to select it.

File Edit Select View Image Layer Colors Tools Filters Wind:

Eraser Tool: Erase to background
or transparency using a brush
Shift+E

8. With the eraser tool selected, we now want to erase one or two of the fruits in the image.
You can change the size of the brush in the tool options window below the tool area. Do
not erase all of the top layer, or we’ll end up back where we started.
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9. Congratulations! You have now selectively coloured your image. If you want to save your
image, your first instinct will probably be to go File -> Save as. This will save the image
as a GIMP file, which basically means we can only view the image using GIMP.

To save the image in a more usable form, we need to go to File -> Export As instead.

In the box that pops up, click on the ‘desktop’ folder to the left, then rename the image to
yourname.png - just like in the example on the next page.
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4 Export Image

Name: Nat.png|

Save in folder: < EWNat @ De Create Folder

Name . Size Modified

Help Export

The next step is to click export (just once - don’t mash it!), then to click export again on
the new box that will pop up. This will save the image in a form we can use anywhere.

Export Image as PNG X

Export Cancel

10. When you are ready to continue to the next activity, select File -> Close All -> Discard
Changes.



Learning Photoshop with GIMP 1

S “[Activity_1_Picture] (imported)-2.0 (RGE color 8-bit ¢ Close All Images ™

File Edit Select WView Image Layer Colors Tools

There is one image with unsaved changes:

[Activity_1_Picture] (imported)-2 3

1 New... Ctrl+MN
Create >

= Open.. Ctrl+ 0O
Ctri+ Alt+0O

Open Location...

Open Recent >

Ctrl+5
Shift+ Ctrl+5
If you close these images now, changes will be lost.

nges and dos

Owerwrite Activity_1_Picture.jpg

= As... Shift+Ctri+E Discard Changes

Create Template...
% Page Setup...
Print...
Ctrl+ Alt+F

Ctri+W
Shift+Ctri+W

Quit Ctrl+Q

Troubleshooting
e When | erase my image, | colour it in instead!
o This means you are missing an alpha channel. Refer to step 6.
e |I'm missing the tool options / layers tab!
o If you click on Windows and hover over Dockable Dialogs, you can respawn
these tabs.

Activity #2: Combining Two Photos Together

For the second activity you will be completing today, you will be combining two images in
photoshop. This is likely the type of photoshop you first thought of when the word ‘photoshop’
was mentioned, and is probably one of the most fun (and funniest) kinds of photoshopping to
do. You can see two examples of two images combined in photoshop below.
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Procedure:

To begin the next activity, you want to repeat a step that you've done before - opening
an image. To do so, go to ‘File’ in the top left of your screen, then go to ‘Open’.

After opening the ‘Open Image’ menu (see below), open each of these files in order:
Resources — Activity #2 — Objects

Open Image X
\ School C

 Size dified

itomatically Detected)

You should see photos of ‘objects’ in this folder - things like spiderman and animals. Find
an image that you like, and open it up by clicking the ‘open’ button.



Learning Photoshop with GIMP 1

42 Open Image *

Name Size Maodified
2

M Sp

= Tiger_O

Dbjact. png

Show All Files

Select File Type (Automatically Detected)

Help Open

Your next step is to make your object transparent, just as you did before in Activity #1.
To do this, go to the ‘layer’ option at the top, move down to the ‘transparency’ option and
hover over it, then, click add alpha channel.
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#u "[Activity_1_Picture] (imported)-2.0 (RGE celor 8-bit gamma integer, GIMP built-in sRGE, 2 layers) 800400 - GIMP

File Edit Select View Image Laye olors Tools Filters Windows Help

Shift+Ctrl+N
New from Visible
Mew Layer Group
& Duplicate Layer Shift+ Ctrl+D
Merge Down

Delete Layer

Stack
Mask
Hes B Transparency = \lpha Channel
GEGL Operation Transform
X Samp rage
Radius | Layer Boundary Size...
i Layerto Image Size
Scale Laye
. Alpha to Selection
Crop to Content Add to Selecti
Subtract from 5Selection

Intersect with Selection

We want to cut our image out from its background to move it into another image. To do
this, we want to erase the background of the image using the eraser tool. Select the
eraser tool by hovering over the buttons on the GIMP toolbar

Next, try erasing some of the background. If you've done everything correctly you should
notice a checkered pattern where you’ve erased, just like in the picture below.

HINT: If you don’t see the checkered pattern when you erase, try adding an alpha
channel again!

Finish cutting out the image from the background. Your final result might look a little like
the picture below.
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The next step is to save our image so that we can move it into another image -- to do
this, go to the ‘file’ option in the top left, and select the ‘export’ option.

In the box that pops up, click on the ‘desktop’ folder to the left, then rename the image to
yourname.png - just like in the example below. Note that the .png at the end of the file is
really important; it allows us to keep the transparent background.

4 Export Image x
Nat.png|

Save in folder: < @ MNat @ Deskiop Desktoy Create Folder

®

Name # Size Modified

n All Files

select File Type (By Extension)

Help
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The next step is to click export (just once - don’t mash it!), then to click export again on
the new box that will pop up.

Export Image as PNG X

Interlacing (Adam7)

Export Cancel

The next step is to close your image using the same File — Close All — Discard
Changes path you used at the end of Activity #1. Make sure you’ve exported your image
first, or you'll lose all your work!

S “[Activity_1_Picture] (imported)-2.0 (RGE color 8-bit ¢ Close All Images i
Edit Select View Image Layer Colors Tools
Ctrl+N
>

Ctrl+O

There is one image with unsaved changes:

[Activity_1_Picture] (imported)-2 &

Ctrl+Ali+ O

>

Ctrl+5

Shift+ Ctrl+S

If you close these images now, changes will be lost.

O Revert

Owverwrite Activity_1_Picture,jpg
S entE Discard Changes

Create Template...

8 PageSetup...

Print... Ctrl+P

mage Location

w in File Manager Ctrl+Ali+F

Ctrl+W
Shift+Ctri+W

Ctrl+Q

Next, you want to open up a background image to put your photoshopped image into. To
do this, repeat the same opening process that you've used before.

Go to ‘File’ in the top left of your screen, then go to ‘Open’.
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After opening the ‘Open Image’ menu, open each of these files in order:

Resources — Activity #2 — Backgrounds

You should see photos of ‘backgrounds’ in this folder - things like sunsets and piers.
Find an image that you like, and open it up by clicking the ‘open’ button.

4= Open Image X

All Files

5
* Select File Type (Automatically Detected)

Help Open

Now let’s open up your edited image on the new background you’ve chosen. To do this
go to ‘File’ at the top left of the screen, then navigate to the ‘Open as Layers’ option.
Find the edited object image that you've saved, then click ‘Open’.
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B Open Image as Layers X
{ mnat @ De:

Name Size Modified

- Nat.png 815.6 kB 12:45

wi All Files

* Select File Type (Automatically Detected)

Help Open

You should now have your image inserted into a new background! If you would like to

change your image in any way (ex. resizing or moving it), feel free to do so using either

the GIMP tools sheet in the resources folder or by experimenting with the tools options.
v “Agyr 1] -




